summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-08-08 14:34:12 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-08-08 14:34:12 +0200
commit3220cd99c42f08bbd959cf73b9fc7b3ca8375676 (patch)
treeae9898536ee5767080b39e82806804fbf9911605 /src/ipcpd/normal/CMakeLists.txt
parent3c80fae407f451691a4a4178617986e32d0c8162 (diff)
parentd13a6dfd0f7a8ebc98cdb59cf0a04a282fa1593d (diff)
downloadouroboros-3220cd99c42f08bbd959cf73b9fc7b3ca8375676.tar.gz
ouroboros-3220cd99c42f08bbd959cf73b9fc7b3ca8375676.zip
Merged in sandervrijders/ouroboros/be-enroll (pull request #189)
ipcpd: normal: Allow exchange of static DIF information
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 7e6d9266..1e291d30 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -14,6 +14,9 @@ include_directories(${CMAKE_BINARY_DIR}/include)
SET(IPCP_NORMAL_TARGET ipcpd-normal CACHE STRING "IPCP_NORMAL_TARGET")
+protobuf_generate_c(STATIC_INFO_SRCS STATIC_INFO_HDRS
+ static_info.proto)
+
set(SOURCE_FILES
# Add source files here
main.c
@@ -22,7 +25,8 @@ set(SOURCE_FILES
ribmgr.c
)
-add_executable (ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES})
+add_executable (ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
+ ${STATIC_INFO_SRCS})
target_link_libraries (ipcpd-normal LINK_PUBLIC ouroboros)
include(MacroAddCompileFlags)