summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-12-03 21:30:34 +0100
committerDimitri Staessens <dimitri.staessens@ugent.be>2017-12-04 12:15:44 +0100
commit961bb67e7dd120d19742ef5c51fbd80c2a18cb12 (patch)
tree5da9e17a77348db36591eaf8cb54c9c064451576 /src/ipcpd/normal/CMakeLists.txt
parentb7fedbe399d561957f99fe7e95aa515b12252abb (diff)
downloadouroboros-0398ae5957ffd49566b7ae4c3fa9b0ad68c3e09f.tar.gz
ouroboros-0398ae5957ffd49566b7ae4c3fa9b0ad68c3e09f.zip
ipcpd: Remove protocol buffers from flow allocator0.8
This will remove google protocol buffers from the flow allocator component in the normal IPCP. It now uses packed structs, as supported by the compilers of choice. Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 087422d9..5ba0c4df 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -14,7 +14,6 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(IPCP_NORMAL_TARGET ipcpd-normal CACHE INTERNAL "")
-protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS flow_alloc.proto)
protobuf_generate_c(ENROLL_PROTO_SRCS ENROLL_PROTO_HDRS enroll.proto
${CMAKE_SOURCE_DIR}/src/lib/ipcp_config.proto)
protobuf_generate_c(KAD_PROTO_SRCS KAD_PROTO_HDRS kademlia.proto)
@@ -46,7 +45,7 @@ set(SOURCE_FILES
)
add_executable(ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
- ${FLOW_ALLOC_SRCS} ${KAD_PROTO_SRCS} ${ENROLL_PROTO_SRCS})
+ ${KAD_PROTO_SRCS} ${ENROLL_PROTO_SRCS})
target_link_libraries(ipcpd-normal LINK_PUBLIC ouroboros-dev)
include(AddCompileFlags)