summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-07-18 11:07:43 +0000
committerSander Vrijders <sander.vrijders@ugent.be>2017-07-18 11:07:43 +0000
commitaff9a39ade6ec39be0b0de7c360a66ed4c6a1e1b (patch)
treeadf6a907d87f11668ccdf0f2df83efd93068f292 /src/ipcpd/normal/CMakeLists.txt
parenta295fd7b24c86f071061aa15e7c82c2463b001b5 (diff)
parent6e739b09bef860a4830328630ea07622bdd79d79 (diff)
downloadouroboros-aff9a39ade6ec39be0b0de7c360a66ed4c6a1e1b.tar.gz
ouroboros-aff9a39ade6ec39be0b0de7c360a66ed4c6a1e1b.zip
Merged in dstaesse/ouroboros/be-dht (pull request #529)
ipcpd: Add DHT as directory in normal IPCP
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 336b0e8f..8c2d4efc 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -15,6 +15,8 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(IPCP_NORMAL_TARGET ipcpd-normal CACHE STRING "IPCP_NORMAL_TARGET")
protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS flow_alloc.proto)
+protobuf_generate_c(KAD_PROTO_SRCS KAD_PROTO_HDRS kademlia.proto)
+
# Add GPB sources of policies last
protobuf_generate_c(FSO_SRCS FSO_HDRS pol/fso.proto)
@@ -22,6 +24,7 @@ set(SOURCE_FILES
# Add source files here
addr_auth.c
connmgr.c
+ dht.c
dir.c
dt.c
dt_pci.c
@@ -42,7 +45,7 @@ set(SOURCE_FILES
)
add_executable(ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
- ${FLOW_ALLOC_SRCS} ${FSO_SRCS})
+ ${FLOW_ALLOC_SRCS} ${FSO_SRCS} ${KAD_PROTO_SRCS})
target_link_libraries(ipcpd-normal LINK_PUBLIC ouroboros)
include(AddCompileFlags)
@@ -53,3 +56,4 @@ endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ipcpd-normal RUNTIME DESTINATION sbin)
add_subdirectory(pol/tests)
+add_subdirectory(tests)