summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-03-20 12:40:35 +0000
committerdimitri staessens <dimitri.staessens@ugent.be>2017-03-20 12:40:35 +0000
commit62e725ced1395b161b0fd66aea433c709850cc57 (patch)
treebd2bd945f8a5313cc3586423650785e106c771db /src/ipcpd/normal/CMakeLists.txt
parentb44cdf4069f30e342dfb80ec3eef7dd5c37367d0 (diff)
parent5fde9be8b30f284b4a249fbf13b08af290b868b1 (diff)
downloadouroboros-62e725ced1395b161b0fd66aea433c709850cc57.tar.gz
ouroboros-62e725ced1395b161b0fd66aea433c709850cc57.zip
Merged in sandervrijders/ouroboros/be-graph (pull request #402)
Be graph
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index af99b3f9..06292c50 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -15,6 +15,7 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(IPCP_NORMAL_TARGET ipcpd-normal CACHE STRING "IPCP_NORMAL_TARGET")
protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS flow_alloc.proto)
+protobuf_generate_c(FSO_SRCS FSO_HDRS fso.proto)
set(SOURCE_FILES
# Add source files here
@@ -25,6 +26,7 @@ set(SOURCE_FILES
fmgr.c
frct.c
gam.c
+ graph.c
main.c
neighbors.c
pff.c
@@ -37,7 +39,7 @@ set(SOURCE_FILES
)
add_executable(ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
- ${FLOW_ALLOC_SRCS})
+ ${FLOW_ALLOC_SRCS} ${FSO_SRCS})
target_link_libraries(ipcpd-normal LINK_PUBLIC ouroboros)
include(AddCompileFlags)