summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-12-02 10:27:09 +0000
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-12-02 10:27:09 +0000
commitc39db00ac0bbed2ec1affa632e83cb52699baec3 (patch)
treee44729348ea0fde27351c9b1759f4dc135a5dba5 /src/ipcpd/normal/CMakeLists.txt
parent113e8f65b6294a46d472b99e39fc9f6d993e808b (diff)
parentb99037eae6a7af058cdb56f316d9c8e4ca603d86 (diff)
downloadouroboros-c39db00ac0bbed2ec1affa632e83cb52699baec3.tar.gz
ouroboros-c39db00ac0bbed2ec1affa632e83cb52699baec3.zip
Merged in sandervrijders/ouroboros/be-addr-pol (pull request #312)
Be addr pol
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt26
1 files changed, 14 insertions, 12 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index 06e41e9c..ca7e1ae2 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -23,17 +23,19 @@ protobuf_generate_c(FLOW_ALLOC_SRCS FLOW_ALLOC_HDRS
protobuf_generate_c(RO_SRCS RO_HDRS ro.proto)
set(SOURCE_FILES
- # Add source files here
- addr_auth.c
- cdap_request.c
- crc32.c
- flat.c
- fmgr.c
- frct.c
- main.c
- ribmgr.c
- shm_pci.c
-)
+ # Add source files here
+ addr_auth.c
+ cdap_request.c
+ crc32.c
+ fmgr.c
+ frct.c
+ main.c
+ path.c
+ ribmgr.c
+ shm_pci.c
+ # Add policies last
+ pol/flat.c
+ )
add_executable (ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
${STATIC_INFO_SRCS} ${FLOW_ALLOC_SRCS} ${RO_SRCS})
@@ -41,7 +43,7 @@ target_link_libraries (ipcpd-normal LINK_PUBLIC ouroboros)
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
- macro_add_compile_flags(ipcpd-normal -DCONFIG_OUROBOROS_DEBUG)
+ macro_add_compile_flags(ipcpd-normal -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ipcpd-normal RUNTIME DESTINATION sbin)