summaryrefslogtreecommitdiff
path: root/src/ipcpd/normal/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2018-02-22 22:35:31 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2018-02-23 11:29:15 +0100
commit130d640d4ba06c45cdd0b9d2787f0a19a3484c9d (patch)
tree0c38f2f633e5f3f5f1a55930ac37e83fbb107288 /src/ipcpd/normal/CMakeLists.txt
parent22b347b44bb2db453080b596e018669cae229e17 (diff)
downloadouroboros-130d640d4ba06c45cdd0b9d2787f0a19a3484c9d.tar.gz
ouroboros-130d640d4ba06c45cdd0b9d2787f0a19a3484c9d.zip
ipcpd: Fix double definition of ipcp config
The import of the IPCP config protobuf message in the enrollment message caused a double definition. The enroll.proto file is deprecated and the definition of the enrollment message is moved to the library to avoid this. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/ipcpd/normal/CMakeLists.txt')
-rw-r--r--src/ipcpd/normal/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/ipcpd/normal/CMakeLists.txt b/src/ipcpd/normal/CMakeLists.txt
index e7e230d2..2446dc00 100644
--- a/src/ipcpd/normal/CMakeLists.txt
+++ b/src/ipcpd/normal/CMakeLists.txt
@@ -14,8 +14,6 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(IPCP_NORMAL_TARGET ipcpd-normal CACHE INTERNAL "")
-protobuf_generate_c(ENROLL_PROTO_SRCS ENROLL_PROTO_HDRS enroll.proto
- ${CMAKE_SOURCE_DIR}/src/lib/ipcp_config.proto)
protobuf_generate_c(KAD_PROTO_SRCS KAD_PROTO_HDRS kademlia.proto)
math(EXPR PFT_EXPR "1 << 12")
@@ -55,7 +53,7 @@ set(SOURCE_FILES
)
add_executable(ipcpd-normal ${SOURCE_FILES} ${IPCP_SOURCES}
- ${KAD_PROTO_SRCS} ${ENROLL_PROTO_SRCS})
+ ${KAD_PROTO_SRCS} ${LAYER_CONFIG_PROTO_SRCS})
target_link_libraries(ipcpd-normal LINK_PUBLIC ouroboros-dev)
include(AddCompileFlags)