summaryrefslogtreecommitdiff
path: root/src/ipcpd/local/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-05-28 19:00:30 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-05-28 19:11:39 +0200
commit97c1341690d998ef8d24abec5b83d6b03e312e0d (patch)
tree9416848007e9d554cd120871dda1c91cdc4958f2 /src/ipcpd/local/CMakeLists.txt
parentc510fb625427a9329668f83ca115645fa1a36091 (diff)
downloadouroboros-97c1341690d998ef8d24abec5b83d6b03e312e0d.tar.gz
ouroboros-97c1341690d998ef8d24abec5b83d6b03e312e0d.zip
ipcpd: IPCP over local memory
This introduces an IPC process that relays data between two local AP's over the shm_du_map. Only configuration it has is a DIF name. It required small modification elsewhere: lib: added support for the IPCP_LOCAL type irm: added support for the IPCP_LOCAL type dif_config: added the IPCP_LOCAL type tools: added support for the IPCP_LOCAL type
Diffstat (limited to 'src/ipcpd/local/CMakeLists.txt')
-rw-r--r--src/ipcpd/local/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/ipcpd/local/CMakeLists.txt b/src/ipcpd/local/CMakeLists.txt
new file mode 100644
index 00000000..c71bbbd1
--- /dev/null
+++ b/src/ipcpd/local/CMakeLists.txt
@@ -0,0 +1,32 @@
+get_filename_component(CURRENT_SOURCE_PARENT_DIR
+ ${CMAKE_CURRENT_SOURCE_DIR} DIRECTORY)
+get_filename_component(CURRENT_BINARY_PARENT_DIR
+ ${CMAKE_CURRENT_BINARY_DIR} DIRECTORY)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CURRENT_SOURCE_PARENT_DIR})
+include_directories(${CURRENT_BINARY_PARENT_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+SET(IPCP_LOCAL_TARGET ipcpd-local CACHE STRING "IPCP_LOCAL")
+
+set(SHIM_LOCAL_SOURCES
+ # Add source files here
+ ${CMAKE_CURRENT_SOURCE_DIR}/main.c)
+
+add_executable (ipcpd-local ${SHIM_LOCAL_SOURCES} ${IPCP_SOURCES})
+target_link_libraries (ipcpd-local LINK_PUBLIC ouroboros)
+
+include(MacroAddCompileFlags)
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+ MACRO_ADD_COMPILE_FLAGS(ipcpd-local -DCONFIG_OUROBOROS_DEBUG)
+endif (CMAKE_BUILD_TYPE MATCHES Debug)
+
+install(TARGETS ipcpd-local RUNTIME DESTINATION bin)
+
+# Enable once ipcp-shim-udp has tests
+# add_subdirectory(tests)