summaryrefslogtreecommitdiff
path: root/src/ipcpd/eth/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2018-10-12 17:17:10 +0200
committerDimitri Staessens <dimitri.staessens@ugent.be>2018-10-12 17:30:49 +0200
commit33e89097c05cb0bb1816a15aa5ef4740d03eb90a (patch)
treefb9aba94899fb954f22a8017e7d9ab164e3be331 /src/ipcpd/eth/CMakeLists.txt
parent7abcc9be25efce7a0848bb2ba79d6f142df0cee9 (diff)
downloadouroboros-33e89097c05cb0bb1816a15aa5ef4740d03eb90a.tar.gz
ouroboros-33e89097c05cb0bb1816a15aa5ef4740d03eb90a.zip
ipcpd: Make Qdisc bypass configurable
This will make bypassing the qdisc configurable, as it might be handy for getting fast data rates but is generally needed. Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be> Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be>
Diffstat (limited to 'src/ipcpd/eth/CMakeLists.txt')
-rw-r--r--src/ipcpd/eth/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipcpd/eth/CMakeLists.txt b/src/ipcpd/eth/CMakeLists.txt
index 6672f93c..e4acdb7f 100644
--- a/src/ipcpd/eth/CMakeLists.txt
+++ b/src/ipcpd/eth/CMakeLists.txt
@@ -82,6 +82,8 @@ if (HAVE_ETH)
"Number of reader threads in Ethernet IPCP")
set(IPCP_ETH_WR_THR 3 CACHE STRING
"Number of writer threads in Ethernet IPCP")
+ set(IPCP_ETH_QDISC_BYPASS false CACHE BOOL
+ "Bypass the Qdisc in the kernel when using raw sockets")
set(ETH_LLC_SOURCES
# Add source files here