summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-03-27 14:17:40 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-03-27 18:04:38 +0200
commit1e83a165d50aacc4e1146186c5691be3326368ca (patch)
treeb23c14f58e2b774d1fa203ac014c3d69a970e21c /src/ipcpd/CMakeLists.txt
parente5d67f7d4df123c2490201447681f2efd553dcc1 (diff)
downloadouroboros-1e83a165d50aacc4e1146186c5691be3326368ca.tar.gz
ouroboros-1e83a165d50aacc4e1146186c5691be3326368ca.zip
ipcpd: flow structure for maintaining flows
The flow structure can be used to maintain the status of flows in ipcp instances. It should probably not be exposed outside ipcpd's. It has a flag FLOW_MT_SAFE which includes locking in case the IPCP has a multithreaded implementation that may require it.
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index bcb5b986..27d41801 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -9,6 +9,7 @@ set(SOURCE_FILES
main.c
pci.c
shm_pci.c
+ flow.c
)
add_executable (ipcpd ${SOURCE_FILES})