summaryrefslogtreecommitdiff
path: root/src/da/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-11 15:50:16 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-11 15:50:16 +0100
commitf78310f4886bad7029cc039971159ab7a97e00af (patch)
treec1609e42197af649ab52888a0c50186218f7a3d8 /src/da/CMakeLists.txt
parent5f3ee106ad32e07e8d00513212eb0968a84b59a1 (diff)
downloadouroboros-f78310f4886bad7029cc039971159ab7a97e00af.tar.gz
ouroboros-f78310f4886bad7029cc039971159ab7a97e00af.zip
Initial build infrastructure
Contains the initial build infrastructure. Cmake was chosen for portability reasons.
Diffstat (limited to 'src/da/CMakeLists.txt')
-rw-r--r--src/da/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/da/CMakeLists.txt b/src/da/CMakeLists.txt
new file mode 100644
index 00000000..050b0f80
--- /dev/null
+++ b/src/da/CMakeLists.txt
@@ -0,0 +1,16 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+set(SOURCE_FILES
+ # Add source files here
+ main.c
+)
+
+add_executable (da ${SOURCE_FILES})
+
+target_link_libraries (da LINK_PUBLIC ouroboros)
+
+install(TARGETS da RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})