summaryrefslogtreecommitdiff
path: root/include/ouroboros/wrap/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-08-31 08:02:08 +0000
committerSander Vrijders <sander.vrijders@ugent.be>2017-08-31 08:02:08 +0000
commitfb4143175b2511cbc915b21ea86e08a3700539f7 (patch)
tree83972ccd8e3debe62f40afae50a3eb27476a0d40 /include/ouroboros/wrap/CMakeLists.txt
parent399164eff1c6d07056ec93e3afd4079611cf9c7b (diff)
parent4060efec26115dbb9e68da67bc482a12b4f80ea8 (diff)
downloadouroboros-fb4143175b2511cbc915b21ea86e08a3700539f7.tar.gz
ouroboros-fb4143175b2511cbc915b21ea86e08a3700539f7.zip
Merged in dstaesse/ouroboros/be-fccntl (pull request #583)
lib: Add fccntl configuration command
Diffstat (limited to 'include/ouroboros/wrap/CMakeLists.txt')
-rw-r--r--include/ouroboros/wrap/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/ouroboros/wrap/CMakeLists.txt b/include/ouroboros/wrap/CMakeLists.txt
index 435b3b70..44c652d5 100644
--- a/include/ouroboros/wrap/CMakeLists.txt
+++ b/include/ouroboros/wrap/CMakeLists.txt
@@ -17,6 +17,8 @@ else ()
# Python assumes C99 since Python 3.6
test_and_set_c_compiler_flag_global(-std=c99)
+ # SWIG generates code for varargs with an unused parameter
+ test_and_set_c_compiler_flag_global(-Wno-unused-parameter)
# CMake > 3.8 deprecates swig_add_module
if (${CMAKE_VERSION} VERSION_LESS 3.8.0)