summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-08-16 18:39:35 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-08-16 18:39:35 +0200
commit1139fc0aa0869485566c0c3ed0c9f2d2ecf00cb4 (patch)
tree9dd6022290a92803be4de438aaed7b70290a08cd /include/ouroboros/CMakeLists.txt
parentfbc0b71d3947cb6047e3e710d606ffc6a39778bc (diff)
downloadouroboros-1139fc0aa0869485566c0c3ed0c9f2d2ecf00cb4.tar.gz
ouroboros-1139fc0aa0869485566c0c3ed0c9f2d2ecf00cb4.zip
lib: Add wrappers for Python
This adds SWIG to the build and wraps the Ouroboros library so that it can be called through Python scripts. If either SWIG or Python cannot be found, no bindings are generated.
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index eb5297d2..ae922b89 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -13,3 +13,5 @@ set(HEADER_FILES
qos.h)
install(FILES ${HEADER_FILES} DESTINATION usr/include/ouroboros)
+
+add_subdirectory(wrap)