summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-05-14 18:32:49 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-05-14 18:32:49 +0200
commitaf1dff6fc06f55d6565589282ac4ebacc53b4d29 (patch)
treedaa33b67da40cd2b7677126fa15fb996cbba25f2 /include/ouroboros/CMakeLists.txt
parentaff55f153ddb247357f59b3740477e90eba527bd (diff)
downloadouroboros-af1dff6fc06f55d6565589282ac4ebacc53b4d29.tar.gz
ouroboros-af1dff6fc06f55d6565589282ac4ebacc53b4d29.zip
lib, ipcpd, irmd: Add QoS cube definition
This adds the QoS cube definition, which is an enum to select which QoS is needed in the IPCP. An application has to use the qos_spec in qos.h to define what it needs. The IRMd will map this unto a qos cube definition. Some headers are now also no longer installed on the system, since they are only to be used within the irmd and ipcps.
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index a42c65fd..5ce99c4c 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -3,23 +3,13 @@ configure_file(
"${CMAKE_CURRENT_BINARY_DIR}/config.h")
set(HEADER_FILES
- bitmap.h
cdap.h
- common.h
da.h
dev.h
dif_config.h
- du_buff.h
flow.h
- instance_name.h
- ipcp.h
irm.h
- list.h
- logs.h
- shm_ap_rbuff.h
- shm_du_map.h
- sockets.h
- utils.h
+ qos.h
)
install(FILES ${HEADER_FILES} "${CMAKE_CURRENT_BINARY_DIR}/config.h"