summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2017-02-10 20:54:38 +0100
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2017-02-10 21:02:44 +0100
commita6309410ffb6b4531044c3b52cb6a79cfdcde231 (patch)
tree54a116be30cfaaaf3bd54f13418cc3a6687cb9cc /include/ouroboros/CMakeLists.txt
parent344f834e85e9c7afc47e19226157c8e834725d2e (diff)
downloadouroboros-a6309410ffb6b4531044c3b52cb6a79cfdcde231.tar.gz
ouroboros-a6309410ffb6b4531044c3b52cb6a79cfdcde231.zip
include: Add header for endianness
This adds a header for dealing with endianness in ouroboros. It is extracted from the byte_order header in the library (which now includes this header). It also exposes the functions ntohl, ntohll, htonl and htonll, necessary for converting 32 and 64 bit values for storage and retrieval from the RIB (which should store multi-byte values in network byte order).
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index 41feb65e..d1a3166c 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -5,6 +5,7 @@ configure_file(
set(HEADER_FILES
cdap.h
dev.h
+ endian.h
errno.h
fcntl.h
fqueue.h