summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-08-11 09:57:31 +0000
committerSander Vrijders <sander.vrijders@ugent.be>2017-08-11 09:57:31 +0000
commitf957c2c499f8093ae86e673e2170f9dbfdcb761a (patch)
tree89cb20e426cb3977337e1d16bdb0a445622d6f75 /CMakeLists.txt
parent2b42b1e1121dfd715a78502a3652d326330b8160 (diff)
parentaecf3810c22ac5e904b0eb7bfe26e3168f3f4f43 (diff)
downloadouroboros-f957c2c499f8093ae86e673e2170f9dbfdcb761a.tar.gz
ouroboros-f957c2c499f8093ae86e673e2170f9dbfdcb761a.zip
Merged in dstaesse/ouroboros/be-apple (pull request #548)
build: Fix compilation on OS X Sierra
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c7266eb..ba56dc33 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,10 @@ set(PACKAGE_BUGREPORT "None"
set(PACKAGE_VERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}"
CACHE STRING "Package version")
+if (APPLE)
+ set(CMAKE_MACOSX_RPATH 1)
+endif()
+
set(CMAKE_SKIP_BUILD_RPATH FALSE)
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
@@ -72,8 +76,11 @@ configure_file(
"${CMAKE_CURRENT_SOURCE_DIR}/ouroboros.pc.in"
"${CMAKE_CURRENT_BINARY_DIR}/ouroboros.pc"
@ONLY)
-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ouroboros.pc"
- DESTINATION "/usr/lib/pkgconfig")
+
+if (NOT APPLE)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ouroboros.pc"
+ DESTINATION "/usr/lib/pkgconfig")
+endif ()
enable_testing()
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})