summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2024-04-06 14:36:37 +0200
committerSander Vrijders <sander@ouroboros.rocks>2024-04-16 14:16:16 +0200
commitce2b8755c6aa4101b0c4c4e097c7bc71493594c0 (patch)
treeb43dc20b0d3e478c936caba797a9976f464ddede /CMakeLists.txt
parentafa421a0396a18c7b40d50e8774ba1d8335754d3 (diff)
downloadouroboros-ce2b8755c6aa4101b0c4c4e097c7bc71493594c0.tar.gz
ouroboros-ce2b8755c6aa4101b0c4c4e097c7bc71493594c0.zip
build: Fix tests with CMake >= 3.29
Removing the testdriver source by the driver name doesn't work anymore in CMake 3.29 because of the following (breaking) change: Changed in version 3.29: The test driver source is listed by absolute path in the build tree. Previously it was listed only as <driverName>. https://cmake.org/cmake/help/latest/command/create_test_sourcelist.html When using CMake 3.29 or above, Ouroboros will use the list POP_FRONT function (introduced in CMake 3.15) to get rid of it. https://cmake.org/cmake/help/latest/command/list.html#pop-front Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c298b981..c08867b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8.12.2...3.28.1)
+cmake_minimum_required(VERSION 2.8.12.2...3.29.1)
cmake_policy(VERSION ${CMAKE_VERSION})
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")