summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2025-03-24 17:50:05 +0100
committerSander Vrijders <sander@ouroboros.rocks>2025-03-30 20:11:31 +0200
commit001c8496ebdacab326988e50df5cdc62ec1a020e (patch)
treeeeae5657895cf99366e26d7db2a5f3c0778db886 /CMakeLists.txt
parentff197dd32d6e6eeca3b9ad7442fe7771dc94fd69 (diff)
downloadouroboros-001c8496ebdacab326988e50df5cdc62ec1a020e.tar.gz
ouroboros-001c8496ebdacab326988e50df5cdc62ec1a020e.zip
build: Use protoc instead of protoc-cbe
Since protobuf-c version 1.5.1 using protoc-c is deprecated: https://github.com/protobuf-c/protobuf-c/pull/758 Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfb0c0fa..e3c7976c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,6 +163,8 @@ if (NOT (PROTOBUF_C_INCLUDE_DIRS AND PROTOBUF_C_LIBRARY
AND PROTOBUF_PROTOC_C_EXECUTABLE))
message(FATAL_ERROR "Protobuf C compiler required but not found. "
"Please install Google Protocol Buffers.")
+else ()
+ message(STATUS "Found protobuf C compiler in ${PROTOBUF_PROTOC_C_EXECUTABLE}")
endif ()
include_directories(${PROTOBUF_C_INCLUDE_DIRS})