summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2017-08-04 04:40:30 -0600
committerDimitri Staessens <dimitri.staessens@ugent.be>2017-08-04 04:40:30 -0600
commit6464bb4b9759b10aa144af2edf98a898a60256c7 (patch)
treecf80113aee8408b68f845ed7467cce3a8e5bb657 /CMakeLists.txt
parent6eb3105f908158130bbc415e7376e3c2d7aafb5e (diff)
parentf85c70fdb6dbbadb903155120892e55b0eff5dda (diff)
downloadouroboros-6464bb4b9759b10aa144af2edf98a898a60256c7.tar.gz
ouroboros-6464bb4b9759b10aa144af2edf98a898a60256c7.zip
Merge branch 'be' of bitbucket.com:dstaesse/ouroboros into be
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c7266eb..85040496 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,6 +81,12 @@ add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})
find_package(ProtobufC REQUIRED)
include_directories(${PROTOBUF_C_INCLUDE_DIRS})
+include(CheckSymbolExists)
+list(APPEND CMAKE_REQUIRED_DEFINITIONS -D_POSIX_C_SOURCE=200809L)
+list(APPEND CMAKE_REQUIRED_DEFINITIONS -D__XSI_VISIBLE=500)
+list(APPEND CMAKE_REQUIRED_LIBRARIES pthread)
+check_symbol_exists(pthread_mutexattr_setrobust pthread.h HAVE_ROBUST_MUTEX)
+
add_subdirectory(src)
add_subdirectory(include)
add_subdirectory(doc)