summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-02-12 20:40:32 +0100
committerDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-02-12 20:40:32 +0100
commit211950a2e5ca3aa74300cea8ee5a97fc0554db8c (patch)
tree3c7eb9eb07a8fcf061261ba18d86d9f2acb7182f /CMakeLists.txt
parent38962e5630e1fd03012b858bb20f799c461fb859 (diff)
parent583efb4910a5287d8ca4a35896f751c167ec0d4d (diff)
downloadouroboros-211950a2e5ca3aa74300cea8ee5a97fc0554db8c.tar.gz
ouroboros-211950a2e5ca3aa74300cea8ee5a97fc0554db8c.zip
Merge branch 'be' of bitbucket.org:ouroboros-rina/ouroboros into be
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c96ce66..6685dc2f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,13 @@ add_subdirectory(include)
add_subdirectory(src)
add_subdirectory(tests)
+include(MacroAddCompileFlags)
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+ MACRO_ADD_COMPILE_FLAGS(ipcp -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(irm -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(da -DCONFIG_OUROBOROS_DEBUG)
+endif (CMAKE_BUILD_TYPE MATCHES Debug)
+
include(FeatureSummary)
print_enabled_features()