summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-06-27 20:40:05 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-06-27 21:01:22 +0200
commitcffd94aae48dac005d820dd667498bbbb09ab117 (patch)
tree2e75316289301a5b78b2b9f9f08dd04e6120f8d9 /CMakeLists.txt
parent25b12e206d22125b7d403d1339738f5bb4a468b5 (diff)
downloadouroboros-cffd94aae48dac005d820dd667498bbbb09ab117.tar.gz
ouroboros-cffd94aae48dac005d820dd667498bbbb09ab117.zip
build: correct sandboxing
paths cannot start with "/" or PREFIX will be omitted. PREFIX must be set before the project() call.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba900645..7b5f5e85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,12 @@ cmake_minimum_required(VERSION 2.8.12.2)
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+LIST(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
+ "${CMAKE_INSTALL_PREFIX}/usr/lib" isSystemDir)
+IF("${isSystemDir}" STREQUAL "-1")
+ SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/usr/lib")
+ENDIF("${isSystemDir}" STREQUAL "-1")
+
project(ouroboros C)
include(GitVersionGen)
@@ -23,12 +29,6 @@ SET(CMAKE_SKIP_BUILD_RPATH FALSE)
SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
-LIST(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
- "${CMAKE_INSTALL_PREFIX}/usr/lib" isSystemDir)
-IF("${isSystemDir}" STREQUAL "-1")
- SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/usr/lib")
-ENDIF("${isSystemDir}" STREQUAL "-1")
-
message(STATUS "Package name is: ${PACKAGE_NAME}")
message(STATUS "Package description is: ${PACKAGE_DESCRIPTION}")
message(STATUS "Package version is: ${PACKAGE_VERSION}")