summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-15 15:43:17 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-15 15:43:17 +0100
commitbd7a8ea8a1adbd6763aea857e72623929b7ad7a4 (patch)
tree168c30a3090d14c654967d0942b4718cd4a979a9 /CMakeLists.txt
parent74dc5818ac8586fcc36915874592c9f4fbb4e6f6 (diff)
downloadouroboros-bd7a8ea8a1adbd6763aea857e72623929b7ad7a4.tar.gz
ouroboros-bd7a8ea8a1adbd6763aea857e72623929b7ad7a4.zip
irmd, lib: Create and destroy IPC Processes
This adds the functionality to create and destroy IPCPs. Upon creation a new process is forked and execve'd. Upon destruction the IPCP is destroyed by killing it with SIGTERM.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1041197c..243e5d6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,15 @@ set(PACKAGE_BUGREPORT "None"
set(PACKAGE_VERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}"
CACHE STRING "Package version")
+SET(CMAKE_SKIP_BUILD_RPATH FALSE)
+SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+
+LIST(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_PREFIX}/lib" isSystemDir)
+IF("${isSystemDir}" STREQUAL "-1")
+ SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+ENDIF("${isSystemDir}" STREQUAL "-1")
+
message(STATUS "Package name is: ${PACKAGE_NAME}")
message(STATUS "Package description is: ${PACKAGE_DESCRIPTION}")
message(STATUS "Package version is: ${PACKAGE_VERSION}")