summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-12 13:27:40 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-12 13:27:40 +0100
commita59d0c7b448597865c679c9d19ee13de742cea02 (patch)
treeef683a73a509eed0aaf2dac9ce197cb2082ea29f /CMakeLists.txt
parent4944a01444f146fdfb1a45ed346b5bc4744c0a45 (diff)
downloadouroboros-a59d0c7b448597865c679c9d19ee13de742cea02.tar.gz
ouroboros-a59d0c7b448597865c679c9d19ee13de742cea02.zip
include: Add logging infrastructure
Adds the logging infrastructure to the prototype. 2 helper scripts are also provided to compile the prototype in either release or debug mode. In debug mode debugging logs are printed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c96ce66..6685dc2f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,13 @@ add_subdirectory(include)
add_subdirectory(src)
add_subdirectory(tests)
+include(MacroAddCompileFlags)
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+ MACRO_ADD_COMPILE_FLAGS(ipcp -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(irm -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(da -DCONFIG_OUROBOROS_DEBUG)
+endif (CMAKE_BUILD_TYPE MATCHES Debug)
+
include(FeatureSummary)
print_enabled_features()