summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-22 17:34:21 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-22 17:34:21 +0100
commit59c9251f3584e8d016c41305ec272bfbf662405a (patch)
treefcac980032d9c414ae086756f3dd7b94d1a7cc55 /CMakeLists.txt
parent815d2d611edec929b970868ac5ae9b3980165d0e (diff)
downloadouroboros-59c9251f3584e8d016c41305ec272bfbf662405a.tar.gz
ouroboros-59c9251f3584e8d016c41305ec272bfbf662405a.zip
src: Rename daemons and add tools folder
This renames the daemons to end with a 'd', as is common for UNIX daemons. It also adds a tools folder, that will hold the tools of the Ouroboros prototype. Examples are a simple echo application, an application to instruct the IRM ...
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6685dc2f..1ca05c95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,11 +46,13 @@ add_subdirectory(include)
add_subdirectory(src)
add_subdirectory(tests)
+# We may have to move this to the subdirs
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
- MACRO_ADD_COMPILE_FLAGS(ipcp -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(ipcpd -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(irmd -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(dad -DCONFIG_OUROBOROS_DEBUG)
MACRO_ADD_COMPILE_FLAGS(irm -DCONFIG_OUROBOROS_DEBUG)
- MACRO_ADD_COMPILE_FLAGS(da -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
include(FeatureSummary)