summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-08-03 13:21:19 +0000
committerdimitri staessens <dimitri.staessens@ugent.be>2017-08-03 13:21:19 +0000
commit3b06d69d61cd677394fa7adf1ffcfa13ab8bac70 (patch)
treeb071a0a3c396aa850a9024000a382165b0c00380 /CMakeLists.txt
parentb92eac2e9f6d686a9e2f748f8097aedbb373395c (diff)
parent5bb3bea07b0ff38e4646ed6f835d9bdac6beced6 (diff)
downloadouroboros-3b06d69d61cd677394fa7adf1ffcfa13ab8bac70.tar.gz
ouroboros-3b06d69d61cd677394fa7adf1ffcfa13ab8bac70.zip
Merged in sandervrijders/ouroboros/be-hurd (pull request #539)
build: Add check for robust mutexes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c7266eb..85040496 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,6 +81,12 @@ add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})
find_package(ProtobufC REQUIRED)
include_directories(${PROTOBUF_C_INCLUDE_DIRS})
+include(CheckSymbolExists)
+list(APPEND CMAKE_REQUIRED_DEFINITIONS -D_POSIX_C_SOURCE=200809L)
+list(APPEND CMAKE_REQUIRED_DEFINITIONS -D__XSI_VISIBLE=500)
+list(APPEND CMAKE_REQUIRED_LIBRARIES pthread)
+check_symbol_exists(pthread_mutexattr_setrobust pthread.h HAVE_ROBUST_MUTEX)
+
add_subdirectory(src)
add_subdirectory(include)
add_subdirectory(doc)