summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2021-07-11 14:01:15 +0200
committerSander Vrijders <sander@ouroboros.rocks>2021-07-12 09:09:44 +0200
commite33be771e4d9e5a88119f4e3af6259e01257c8a5 (patch)
tree7097dbed859814fb100e61c3af66b040e191f12d /src/ipcpd/CMakeLists.txt
parentd064464945878df38127279233bc433fef529c90 (diff)
downloadouroboros-e33be771e4d9e5a88119f4e3af6259e01257c8a5.tar.gz
ouroboros-e33be771e4d9e5a88119f4e3af6259e01257c8a5.zip
ipcpd: Reduce Linux slack timer
This will reduce the linux high resolution slack timer in IPCPs. Linux default for userspace processes is 50us. It is configurable at build using IPCP_LINUX_SLACKTIMER_NS. Default is now 1us. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index fb6162cd..1ce1bc0d 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -16,6 +16,10 @@ set(IPCP_CONN_WAIT_DIR TRUE CACHE BOOL
"Check the running state of the directory when adding a dt connection")
set(DHT_ENROLL_SLACK 50 CACHE STRING
"DHT enrollment waiting time (0-999, ms)")
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ set(IPCP_LINUX_TIMERSLACK_NS 1000 CACHE STRING
+ "Slack value for high resolution timers on Linux systems.")
+endif ()
if ((IPCP_QOS_CUBE_BE_PRIO LESS 0) OR (IPCP_QOS_CUBE_BE_PRIO GREATER 99))
message(FATAL_ERROR "Invalid priority for best effort QoS cube")